WifInfo V1.0.0 Release candidate


  • Staff

    Bonjour à tous,

    Le Père-noël étant de sortie, je viens de publier la release candidate de WifInfo que vous trouverez sur le repo officiel.

    Je n'ai pas eu trop le temps de faire la documentation, mais j'ai mis à jour l'article du blog présentant la carte ici, et enfin, décrit vite fait le processus OTA ici pour Remora et WifInfo.

    Merci de vos retours, j'enrichirais la documentation en fonction de vos remarques.

    Je vous souhaite à tous de passer d'excellentes fêtes de fin d'année.



  • Merci Charles.
    Passes de bonnes fêtes toi aussi :smiley:



  • Merci pour cette mise a jour.

    Pour les utilisateurs de Domoticz que conseilles tu ? Stp



  • @Charles

    Salut,

    J'ai presque reussit une mise a jour de cette version.

    Ma config Arduino IDE 1.6.5 W7 avec la derniere staging dispo (wifinfo n y apparait pas, aussi bien en 2.0 RC1 que RC2).

    0_1451152196364_config.jpg

    Je serveur WEB semble demarrer mais ne trouve pas index.htm

    malgré ceci dans les logs

    HTTP server started
    handleFileRead /index.htm
    handleNotFound(/index.htm)
    handleFileRead /index.htm
    

    et effectivement mon navigateur chrome m'affiche file not found

    Que faire ?


  • Staff

    Ouais, les staging ne sont plus d'actualités, ils ont une date inférieure à la release.

    La dernière release utilise le SDK 1.3 et le repo la V1.5 du SDK qui semble beaucoup plus stable mais aussi ça contient la board WifInfo.

    Donc, en attendant la prochaine release de l'environnement, je te conseille de supprimer le staging via board/manager et de passer en mode "git" cf https://github.com/esp8266/Arduino c'est ce que je fais.



  • bonjour,
    je débute dans l'utilisation de l'esp8266 j'ai une carte nodemcu v1.0.
    moi avec ma config : Arduino IDE 1.6.5 install des board via la procédure "GIT" .
    j'ai "File Not Found" qui s’affiche sur ma page web.
    Par contre si j'upload le sketch de la version esp8266_WifInfo, la j'ai bien la page web qui fonctionne.
    je pense que je vais rester sur la première version le temps que l’environnent soit à jour.



  • @difful

    Je suis revenu aussi a cette version, mais son probleme est que le json retourné n'est pas "valide"

    ![0_1451338385519_Capture.JPG](Uploading 100%)

    En attendant de mieux.



  • Bonjour,

    J’ai réussi à faire l'update grâce au post mise en œuvre de WifInfo.

    mon erreur venait qu'il faut charger les fichiers du dossier "DATA" dans le SPIFSS.

    Je fais donc une procédure qui a marche pour moi et peut être pour d'autre aussi.

    Il faut télécharger le fichier esp8266fs.jar .
    https://github.com/esp8266/arduino-esp8266fs-plugin/releases/download/0.1.3/ESP8266FS-0.1.3.zip

    Le décompresser et mettre le fichier dans vôtres répertoire ou est installer arduino IDE
    Typiquement : "C:\Program Files (x86)\Arduino\tools"

    Créez un répertoire " ESP8266FS " et un sous répertoire " tool "

    Ce qui nous donne : "C:\Program Files (x86)\Arduino\tools\ESP8266FS\tool"

    Après cela démarrer arduino IDE une nouvelle option apparait dans outils « ESP8266 sketch data upload ».

    Compiler et uploader WifInfo dans votre esp8266, quand c’est fini.
    Aller dans « outils » et cliquez sur « ESP8266 sketch data upload » après un certain temps car il faut uploader (3Mbit il me semble) à 115200 baud.

    une fois cela fini on peut accéder à notre WifInfo normalement.

    merci à mjeanne d'avoir diffuser l'info qu'il me manquais.
    Et un grand merci à toi Charles pour le travail que tu fourni.


  • Staff

    @difful
    Oui j'avais oublié ce point, la doc est à jour ici je viens d'ajouter ce point.
    Merci du retour


Log in to reply
 

Looks like your connection to hallard.me's community was lost, please wait while we try to reconnect.