Issues about TH02 with NODEMCU V1.0



  • Hello Hallard! :)

    Recently I met up with a problem. I found when I run the sample program from the TH02 library on NODEMCU 1.0, the results are always null(-50 temperature and -24 humidity). I think it is some problem with I2C. I just use Wire.begin(4, 5) to make GPIO4 the SDA and GPIO5 the SCL.

    I hope you will see this and reply to me soon! Thanks!!!


  • Staff

    @Zemin-Piao
    I'm sorry but I switched my temp/hum sensor chip, now I'm using SI7021 sensors because TH02 is not full I2C compliance, IE it can't be on the same I2C bus with other I2C devices, that's the thing I saw later (I should have read carefully datasheet before) so the reason of my change.

    By the Way I had some issue with also with SI7021 and NodeMCU because it seems clock stretching may sometimes cause issue, so may be it's the issue you have also.

    I'm sorry I won't be able to investigate on this issue since I do not use these sensors anymore but you can have some si7021 cheaper and better then th02 here 5V and 3V3 compatible for $3 ;-)



  • Hello,
    I have the same problem with an Arduino breakout with Intel Edison. Charles observation can be the explanation because on the breakout bus 6 is only available and INTEL might have used the I2C for other purposes preventing the TH02 from working properly.



  • @Charles
    Thanks for the explanation I'll cross check with other Edison users but I am sure that is the reason. We have also checked the sensor HTU21DF that works properly.
    Thanks again for the job


Log in to reply
 

Looks like your connection to hallard.me's community was lost, please wait while we try to reconnect.